Well, it’s been a little while since I updated this one and I had a couple people inquiring about it’s progress so here it is.  When we last left off, I had gotten the car to a point where it actually looked decent enough where it wasn’t embarrassing to drive around anymore an that’s where I left it.   Here’s a quick recap of what I started with.

With the Works…  still pretty fugly.

Mounted some PGC10 mirrors, started on some bodywork and badly needed bumpers…

Bodywork mostly done, shaved front and rear sidemarkers, antenna,  mirror, license plate lights, trunk emblems, keyhole, custom bumpers and bumper fillers.  More info HERE, and HERE.

And this is how I left it.  I’m okay with rocking the primer for a little while until I can decide on a color…  at least it’s all ONE color now.

I daily drove it all last summer as the anemic 4K-C motor worked it’s way closer and closer to the grave.  Bad idle circuits… leaking oil form every orifice but I refused to put any money into a motor I knew I wasn’t keeping so I dealt with it until winter came, at which point I decided to put it under the knife again.  (Take into consideration that this is my own personal car so I only work on it a couple of times a week after hours so this is about 5 months of work you’re seeing here.)   I stumbled across a guy that had an neglected AE86 shell sitting in his back yard for a couple years.   Those of you familiar with the 4AGE swap into the KP61 chassis know that  it’s a pretty involved process that requires almost an entire AE86 chassis…  harness, transmission, pedal assembly etc. so this was an ideal situation.  We had no idea if it ran or not but I ended up trading a bike wait, make that bicycle for it which was probably worth the price of the wheels on the car so I figured it wasn’t too bad of a trade whether it ran or not.   This is how the beauty showed up….

Nice right?  When I said it was a shell, I wasn’t joking.  And check out the engine bay…

Well, you get what you pay for.  The first step was to shovel out all the leaves, dirt, spider nests and broken bottles from inside the car.   Next up, I thought it would make more sense to try to get this motor running while it was still in the car that way I could eliminate any wiring issues that  may come with the swap.   The first thing to do was make sure the motor wasn’t seized so I turned the crank by hand…  so far so good.  Next up was draining ALL the fluids because who knows how long they were in there for.   Crank the motor…  nothing.   Fix some bad connections until the starter actually turns over…  hmm…  no fuel.  Time to drop the tank.

It turns out the fuel pump was seized after sitting too long so I gave my friends at Solid Autoworks a call to see if they had any pumps laying around.  They just so happened to have a stock WRX fuel pump they just pulled out of a customers car so I snatched that up for free and dropped it in.  Score!   Well sort of….   It gets fuel now but no spark.  I ended up pulling almost every connector and cleaning the terminals because there was just so much corrosion everywhere in this car that I was dealing with a gazillion electrical shorts.   Crank it again,  it runs!   Barely.  There was a good deal of questionable wiring done to this car by the previous owner that I had to redo.  This was the MAF harness….  look suspect?  Before and after some proper soldering and heatshrink.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

And what do you know, after a few weeks of trouble shooting it finally runs.  BOOYEAH!  Now that I know the motor runs properly, I can now start stripping the harness of everything I’m not going to use in the Starlet.  First up is the engine harness.

And then the chassis harness… does that look like fun?

And here’s what I ended up pulling out…

The beauty of stripping the harness while it’s still in the car is that you can start the motor occasionally to make sure you didn’t remove anything critical.  I’ve seen many a harness stripping go bad because people just get in there and start tearing stuff out and then they wonder why the car doesn’t run anymore.    Now that’s done its time pull out the big stuff.  The great thing about the AE86 is that many of the parts cross over to quite a few of other Toyota chassis so my goal was to keep everything I though I may use on another JDML car down the road.

Electrical connectors, relays, nuts, bolts, all that stuff will eventually come in handy so I stripped it bare.  And don’t worry, this chassis was way too far gone to ever see a restoration.  The previous owner actually used spray foam insulation so fill up all the rust holes this car had…  I haven’t seen that one yet.  Off to the scrapyard.

Next up was to strip down and prep that nasty motor.   I’ve never seen so much corrosion on a motor before, seriously this thing looked like a shipwreck…..  I still can’t believe I actually got it running.

I didn’t get too in depth with it because I think I’ll eventually go with a hi-compression small port motor anyways but there was no way I was sticking it in my car looking like that.   Everything was taken off the motor and cleaned.

The KP doesn’t have power steering so I decided to make my own p.s. delete crank pulley to clean things up a bit by simply sticking it in the band saw and grinding it flat on the belt sander.

 

 

 

 

 

 

 

 

Pulled and stripped the valve covers.

I was shocked to see how clean it was inside the motor for how nasty it looked on the outside.  Good leakdown and compression numbers too.

I ended up picking up some OEM NGK wires after a bit of searching.  And you KNOW the valve covers had to be gold.  I also heat wrapped this header that came in the trunk of the Starlet when I got it because I got stranded in my last AE86 at night in the canyon because I wasn’t running a heatsheild on the header and it melted the distributor cap.  No fun.

I deleted all the timing belt covers completely because I wanted this motor to look pretty raw.  I also did all the basic maintainence as well, timing belt, waterpump, thermostat, plugs, cap, rotor, oils seals etc.  It’s almost ready to drop in, I just have to find a way to make the oil filter/cooler housing  cooperate with those sexy T3 motor mounts.

Time to yank that leaky 4K-C.  Good riddance!

And this is about where I’m at now, time to strip the KP harness of everything that used to control the old motor and clean up that nasty engine bay….  looks like I’ve got my work cut out for me.

There’s still a TON of work to be done but hopefully I’ll be firing this thing up before summer hits if all goes well.   And by the way our new arrivals from Japan hit the port on Monday so we should be seeing them later next week, STAY TUNED!